#104 ✓resolved
Hans de Graaff

private config method name is too common and may cause conflicts

Reported by Hans de Graaff | May 8th, 2009 @ 04:30 AM

As it happens I'm trying to include AuthLogic into an existing application which has a global configuration holder called config. This conflicts with authlogic because of the privately declared config method in lib/authlogic/acts_as_authentic/base.rb.

I think it would make sense to change the name of this method in authlogic to include an authlogic specific prefix, so that the chance of a similar namespace clash is reduced.

Comments and changes to this ticket

Please Sign in or create a free account to add a new ticket.

With your very own profile, you can contribute to projects, track your activity, watch tickets, receive and update tickets through your email and much more.

New-ticket Create new ticket

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile ยป

Object based authentication solution that handles all of the non sense for you. It's as easy as ActiveRecord is with a database.

People watching this ticket