#22 ✓resolved
Jonas

Compatibility with Spatial Adapter for Rails plugin

Reported by Jonas | November 10th, 2008 @ 09:50 AM

There seems to be a small problem regarding compatibility of Searchlogic and the Spatial Adapter for Rails plugin. Spatial Adapter somehow manipulates the column definitions which results in Searchlogic not working anymore.

The error i get is the following:

compile error C:/devel/workspace/wall/vendor/plugins/searchlogic-1.5.3/lib/searchlogic/conditions/base.rb:404: syntax error, unexpected kEND C:/devel/workspace/wall/vendor/plugins/searchlogic-1.5.3/lib/searchlogic/conditions/base.rb:418: syntax error, unexpected $end, expecting kEND

The error can be reproduced by simply installing GeoRuby and the Spatial Adapter plugin as described here: http://georuby.rubyforge.org/spa... .

I could fix the problem when changing the code that checks options[:column] in lib/searchlogic/conditions/base.rb:398 from


options[:column] = options[:column].name if options[:column].class < ::ActiveRecord::ConnectionAdapters::Column

to


options[:column] = options[:column].name if options[:column].class <= ::ActiveRecord::ConnectionAdapters::Column

Is there any specific reason why it has to be a subclass of ActiveRecord::ConnectionAdapters::Column and can't be the same as ActiveRecord::ConnectionAdapters::Column?

Comments and changes to this ticket

Please Sign in or create a free account to add a new ticket.

With your very own profile, you can contribute to projects, track your activity, watch tickets, receive and update tickets through your email and much more.

New-ticket Create new ticket

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile ยป

Provides common named scopes and object based searching.

People watching this ticket

Pages