#108 ✓resolved
mrcsparker

Ruby 1.9 compat

Reported by mrcsparker | July 28th, 2009 @ 05:13 PM

When I try to run searchlogic under Ruby 1.9 I get:

'wrong argument type Proc (expected Binding) (TypeError)'

The fix for this is to change:

  • eval("options", scopes[key])

to

  • eval("options", scopes[key].binding)

in the named_scopes/conditions.rb file.

Comments and changes to this ticket

  • Ben Johnson

    Ben Johnson July 30th, 2009 @ 02:45 AM

    • State changed from “new” to “resolved”

    Awesome, good find. This has been applied and will be in the next release.

  • gecuvygoba

    gecuvygoba June 25th, 2019 @ 05:57 AM

    Ruby has the all comapt on this that was good among some details they release its 1.9 version that have many changes on it. I need to read the manual of this that was on bid4papers.com reviews this has the all aspection that was useful at this stage.

Please Sign in or create a free account to add a new ticket.

With your very own profile, you can contribute to projects, track your activity, watch tickets, receive and update tickets through your email and much more.

New-ticket Create new ticket

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile ยป

Provides common named scopes and object based searching.

People watching this ticket

Tags

Pages